Skip to content

1002 Business

Statement

Metadata

  • 作者: CHEN, Yue
  • 单位: 浙江大学
  • 代码长度限制: 16 KB
  • 时间限制: 800 ms
  • 内存限制: 64 MB

As the manager of your company, you have to carefully consider, for each project, the time taken to finish it, the deadline, and the profit you can gain, in order to decide if your group should take this project. For example, given 3 projects as the following:

  • Project[1] takes 3 days, it must be finished in 3 days in order to gain 6 units of profit.
  • Project[2] takes 2 days, it must be finished in 2 days in order to gain 3 units of profit.
  • Project[3] takes 1 day only, it must be finished in 3 days in order to gain 4 units of profit.

You may take Project[1] to gain 6 units of profit. But if you take Project[2] first, then you will have 1 day left to complete Project[3] just in time, and hence gain 7 units of profit in total. Notice that once you decide to work on a project, you have to do it from beginning to the end without any interruption.

Input Specification

Each input file contains one test case. For each case, the first line gives a positive integer N (\le 50), and then followed by N lines of projects, each contains three numbers P, L, and D where P is the profit, L the lasting days of the project, and D the deadline. It is guaranteed that L is never more than D, and all the numbers are non-negative integers.

Output Specification

For each test case, output in a line the maximum profit you can gain.

Sample Input

4
7 1 3
10 2 3
6 1 2
5 1 1

Sample Output

18

Solution

#include <bits/stdc++.h>
using namespace std;

const int N = 1100;
int n, f[N];

struct E {
    int P, L, D;
    bool operator<(const E &other) const {
        return D < other.D;
    }
} e[N];

int main() {
    scanf("%d", &n);
    for (int i = 1; i <= n; ++i) {
        scanf("%d%d%d", &e[i].P, &e[i].L, &e[i].D);
    }
    sort(e + 1, e + 1 + n);
    for (int i = 1; i <= n; ++i) {
        for (int j = e[i].D - e[i].L; j >= 0; --j) {
            f[j + e[i].L] = max(f[j + e[i].L], f[j] + e[i].P);
        }
    }
    int res = 0;
    for (int i = 0; i <= 1000; ++i) res = max(res, f[i]);
    printf("%d\n", res);
    return 0;
}

Last update: May 4, 2022
Back to top