Skip to content

1073 多选题常见计分法

Statement

Metadata

  • 作者: CHEN, Yue
  • 单位: 浙江大学
  • 代码长度限制: 16 KB
  • 时间限制: 400 ms
  • 内存限制: 64 MB

批改多选题是比较麻烦的事情,有很多不同的计分方法。有一种最常见的计分方法是:如果考生选择了部分正确选项,并且没有选择任何错误选项,则得到 50% 分数;如果考生选择了任何一个错误的选项,则不能得分。本题就请你写个程序帮助老师批改多选题,并且指出哪道题的哪个选项错的人最多。

输入格式

输入在第一行给出两个正整数 N(\le1000)和 M(\le100),分别是学生人数和多选题的个数。随后 M 行,每行顺次给出一道题的满分值(不超过 5 的正整数)、选项个数(不少于 2 且不超过 5 的正整数)、正确选项个数(不超过选项个数的正整数)、所有正确选项。注意每题的选项从小写英文字母 a 开始顺次排列。各项间以 1 个空格分隔。最后 N 行,每行给出一个学生的答题情况,其每题答案格式为 (选中的选项个数 选项1 ……),按题目顺序给出。注意:题目保证学生的答题情况是合法的,即不存在选中的选项数超过实际选项数的情况。

输出格式

按照输入的顺序给出每个学生的得分,每个分数占一行,输出小数点后 1 位。最后输出错得最多的题目选项的信息,格式为:错误次数 题目编号(题目按照输入的顺序从1开始编号)-选项号。如果有并列,则每行一个选项,按题目编号递增顺序输出;再并列则按选项号递增顺序输出。行首尾不得有多余空格。如果所有题目都没有人错,则在最后一行输出 Too simple

输入样例 1

3 4 
3 4 2 a c
2 5 1 b
5 3 2 b c
1 5 4 a b d e
(2 a c) (3 b d e) (2 a c) (3 a b e)
(2 a c) (1 b) (2 a b) (4 a b d e)
(2 b d) (1 e) (1 c) (4 a b c d)

输出样例 1

3.5
6.0
2.5
2 2-e
2 3-a
2 3-b

输入样例 2

2 2 
3 4 2 a c
2 5 1 b
(2 a c) (1 b)
(2 a c) (1 b)

输出样例 2

5.0
5.0
Too simple

Solution

#include <algorithm>
#include <cmath>
#include <cstring>
#include <iostream>
using namespace std;
struct joy {
    int grade, num, choice, wrong[5] = {0}, max = -2, flag[5] = {0}, number;
    int tr[122] = {0};
};
void print(joy x) {
    int i;
    for (i = 0; i < 5; i++) {
        if (x.flag[i]) {
            printf("%d %d-%c\n", x.wrong[i], x.number, i + 'a');
        }
    }
}
int main() {
    int n, m, i, j, k, a, b[122] = {0}, temp, h, max = -1;
    char p, x;
    double sum = 0.0;
    struct joy list[100];
    cin >> n >> m;
    for (i = 0; i < m; i++) {
        cin >> list[i].grade >> list[i].num >> list[i].choice;
        list[i].number = i + 1;
        for (j = 0; j < list[i].choice; j++) {
            scanf(" %c", &p);
            // cout<<p<<endl;
            /*if(p==10){
                    break;
            }*/
            temp = p;
            list[i].tr[temp]++;
        }
    }
    int flag = 1;
    int count = 0;
    for (i = 0; i < n; i++) {
        sum = 0.0;
        for (j = 0; j < m; j++) {
            count = 0, flag = 1;      // add
            memset(b, 0, sizeof(b));  // add
            scanf(" %c %d", &x, &a);
            // cout<<a<<endl;
            for (k = 0; k < a; k++) {
                scanf(" %c", &p);
                // cout<<p<<endl;
                temp = p;
                b[temp]++;
            }
            cin >> x;  // add
            for (h = 97; h < 102; h++) {
                if (b[h] == list[j].tr[h]) {
                    if (b[h])
                        count++;
                } else if (b[h] > list[j].tr[h]) {
                    flag = 0;
                    list[j].wrong[h - 'a']++;  // replace
                } else
                    list[j].wrong[h - 'a']++;
                if (list[j].wrong[h - 'a'] > list[j].max && list[j].wrong[h - 'a'])
                    list[j].max = list[j].wrong[h - 'a'];  // add
            }
            if (list[j].max > max)
                max = list[j].max;
            // cout<<count<<endl;
            if (flag) {                         // remove
                if (count == list[j].choice) {  // choice replace num
                    sum += 1.0 * list[j].grade;
                } else {
                    sum += list[j].grade / 2.0;
                }
            }  // remove
        }
        // cout<<sum<<endl;
        /*for(j=0; j<m; j++){
        if(flag){
            if(count==list[j].num){
                    sum+=1.0*list[j].grade;
            }else{
                sum+=list[j].grade/2.0;
                }
    }
    cin>>x;
}*/
        printf("%.1f\n", sum);
    }
    for (i = 0; i < m; i++) {
        for (j = 0; j < 5; j++) {
            if (list[i].wrong[j] == list[i].max)
                list[i].flag[j] = 1;
        }
    }
    flag = 1;
    for (i = 0; i < m; i++) {
        if (list[i].max == max) {
            print(list[i]);
            flag = 0;
        }
    }
    if (flag)
        cout << "Too simple\n";
}

Last update: May 4, 2022
Back to top