1072 开学寄语
Statement
Metadata
- 作者: CHEN, Yue
- 单位: 浙江大学
- 代码长度限制: 16 KB
- 时间限制: 400 ms
- 内存限制: 64 MB
下图是上海某校的新学期开学寄语:天将降大任于斯人也,必先删其微博,卸其 QQ,封其电脑,夺其手机,收其 ipad,断其 wifi,使其百无聊赖,然后,净面、理发、整衣,然后思过、读书、锻炼、明智、开悟、精进。而后必成大器也!
本题要求你写个程序帮助这所学校的老师检查所有学生的物品,以助其成大器。
输入格式
输入第一行给出两个正整数 N(
输出格式
顺次检查每个学生携带的物品,如果有需要被查缴的物品存在,则按以下格式输出该生的信息和其需要被查缴的物品的信息(注意行末不得有多余空格):
最后一行输出存在问题的学生的总人数和被查缴物品的总数。输入样例
输出样例
Solution
#include <bits/stdc++.h>
using namespace std;
int main() {
int n, m, i, j, tot1 = 0, tot2 = 0, total, flag;
string s, name;
map<string, int> q;
cin >> n >> m;
for (i = 0; i < m; i++) {
cin >> s;
q[s] = 2;
}
for (i = 0; i < n; i++) {
cin >> name;
cin >> total;
flag = 0;
for (j = 0; j < total; j++) {
cin >> s;
if (q[s] == 2) {
if (flag) {
tot2++;
cout << " " << s;
} else {
tot1++, tot2++;
flag = 1;
cout << name << ": " << s;
}
}
}
if (flag)
printf("\n");
}
cout << tot1 << " " << tot2 << endl;
}
Last update: May 4, 2022