1046 划拳
Statement
Metadata
- 作者: CHEN, Yue
- 单位: 浙江大学
- 代码长度限制: 16 KB
- 时间限制: 400 ms
- 内存限制: 64 MB
划拳是古老中国酒文化的一个有趣的组成部分。酒桌上两人划拳的方法为:每人口中喊出一个数字,同时用手比划出一个数字。如果谁比划出的数字正好等于两人喊出的数字之和,谁就赢了,输家罚一杯酒。两人同赢或两人同输则继续下一轮,直到唯一的赢家出现。
下面给出甲、乙两人的划拳记录,请你统计他们最后分别喝了多少杯酒。
输入格式
输入第一行先给出一个正整数
喊
是喊出的数字,划
是划出的数字,均为不超过 100 的正整数(两只手一起划)。 输出格式
在一行中先后输出甲、乙两人喝酒的杯数,其间以一个空格分隔。
输入样例
输出样例
Solution
#include <bits/stdc++.h>
using namespace std;
int main() {
int t, tot1 = 0, tot2 = 0, total;
cin >> t;
while (t--) {
int a, b, c, d;
scanf("%d%d%d%d", &a, &b, &c, &d);
total = a + c;
if (b == total && d != total)
tot2++;
else if (d == total && b != total)
tot1++;
}
cout << tot1 << " " << tot2 << endl;
}
Last update: May 4, 2022