Skip to content

1043 输出PATest

Statement

Metadata

  • 作者: CHEN, Yue
  • 单位: 浙江大学
  • 代码长度限制: 16 KB
  • 时间限制: 400 ms
  • 内存限制: 64 MB

给定一个长度不超过 10^4 的、仅由英文字母构成的字符串。请将字符重新调整顺序,按 PATestPATest.... 这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按 PATest 的顺序打印,直到所有字符都被输出。

输入格式

输入在一行中给出一个长度不超过 10^4 的、仅由英文字母构成的非空字符串。

输出格式

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例

redlesPayBestPATTopTeePHPereatitAPPT

输出样例

PATestPATestPTetPTePePee

Solution

#include <bits/stdc++.h>
using namespace std;
int main() {
    string s;
    cin >> s;
    int i, len = s.size(), n[6] = {0}, max = 0;
    for (i = 0; i < len; i++) {
        if (s[i] == 'P')
            n[0]++;
        else if (s[i] == 'A')
            n[1]++;
        else if (s[i] == 'T')
            n[2]++;
        else if (s[i] == 'e')
            n[3]++;
        else if (s[i] == 's')
            n[4]++;
        else if (s[i] == 't')
            n[5]++;
    }
    for (i = 0; i < 6; i++) {
        if (n[i] > max)
            max = n[i];
    }
    for (i = 0; i < max; i++) {
        if (n[0]) {
            printf("P");
            n[0]--;
        }
        if (n[1]) {
            printf("A");
            n[1]--;
        }
        if (n[2]) {
            printf("T");
            n[2]--;
        }
        if (n[3]) {
            printf("e");
            n[3]--;
        }
        if (n[4]) {
            printf("s");
            n[4]--;
        }
        if (n[5]) {
            printf("t");
            n[5]--;
        }
    }
    cout << "\n";
}

Last update: May 4, 2022
Back to top