Skip to content

1032 挖掘机技术哪家强

Statement

Metadata

  • 作者: CHEN, Yue
  • 单位: 浙江大学
  • 代码长度限制: 16 KB
  • 时间限制: 200 ms
  • 内存限制: 64 MB

为了用事实说明挖掘机技术到底哪家强,PAT 组织了一场挖掘机技能大赛。现请你根据比赛结果统计出技术最强的那个学校。

输入格式

输入在第 1 行给出不超过 10^5 的正整数 N,即参赛人数。随后 N 行,每行给出一位参赛者的信息和成绩,包括其所代表的学校的编号(从 1 开始连续编号)、及其比赛成绩(百分制),中间以空格分隔。

输出格式

在一行中给出总得分最高的学校的编号、及其总分,中间以空格分隔。题目保证答案唯一,没有并列。

输入样例

6
3 65
2 80
1 100
2 70
3 40
3 0

输出样例

2 150

鸣谢用户 米泰亚德 补充数据!

Solution

/*#include<bits/stdc++.h>
using namespace std;
map<int,int>q;
int cmp(const pair<int, int>&x,  const pair<int, int>&y)
{
    return x.second > y.second;
}
int main()
{
        int t;
        cin>>t;
        int i;
        int a,b;
        for(i=0;i<t;i++)
        {
                cin>>a>>b;
                q[a]+=b;
        }
        vector<int, int>v;
        for(auto it=q.begin();it!=q.end();it++)
          q.push_back(make_pair(it->first,it->second));
        sort(q.begin(),q.end(),cmp);
        map<int,int>::iterator it;
        it=q.begin();
        cout<<it->first<<" "<<it->second<<endl;
}*/

#include <bits/stdc++.h>
using namespace std;
int main() {
    int t;
    cin >> t;
    int i, a, b;
    map<int, int> q;
    for (i = 0; i < t; i++) {
        cin >> a >> b;
        q[a] += b;
    }
    map<int, int>::iterator it, max;
    it = max = q.begin();
    for (it++; it != q.end(); it++) {
        if (it->second > max->second)
            max = it;
    }
    cout << max->first << " " << max->second << endl;
}

Last update: May 4, 2022
Back to top