1028 人口普查
Statement
Metadata
- 作者: CHEN, Yue
- 单位: 浙江大学
- 代码长度限制: 16 KB
- 时间限制: 200 ms
- 内存限制: 64 MB
某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。
这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过 200 岁的老人,而今天是 2014 年 9 月 6 日,所以超过 200 岁的生日和未出生的生日都是不合理的,应该被过滤掉。
输入格式
输入在第一行给出正整数 yyyy/mm/dd
(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。
输出格式
在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。
输入样例
输出样例
Solution
#include <bits/stdc++.h>
using namespace std;
#define MAXN 100000
struct pp {
string s;
int a, b, c;
} q[MAXN];
int jude(int a, int b, int c) {
if (a > 2014 || a < 1814)
return 0;
else if (a == 2014) {
if (b > 9)
return 0;
else if (b == 9) {
if (c > 6)
return 0;
}
} else if (a == 1814) {
if (b < 9)
return 0;
else if (b == 9) {
if (c < 6)
return 0;
}
}
return 1;
}
int comp(pp x, pp y) {
if (x.a > y.a)
return 0;
else if (x.a == y.a) {
if (x.b > y.b)
return 0;
else if (x.b == y.b) {
if (x.c > y.c)
return 0;
}
}
return 1;
}
int main() {
string s;
int n, i, a, b, c, j = 0;
cin >> n;
for (i = 0, j = 0; i < n; i++) {
cin >> s;
scanf("%d/%d/%d", &a, &b, &c);
if (jude(a, b, c)) {
q[j].s = s;
q[j].a = a, q[j].b = b, q[j].c = c;
j++;
}
}
if (j >= 2)
sort(q, q + j, comp);
printf("%d", j);
if (j > 1)
cout << " " << q[0].s << " " << q[j - 1].s;
else if (j == 1)
cout << " " << q[0].s << " " << q[0].s;
cout << endl;
}
Last update: May 4, 2022