1019 数字黑洞
Statement
Metadata
- 作者: CHEN, Yue
- 单位: 浙江大学
- 代码长度限制: 16 KB
- 时间限制: 200 ms
- 内存限制: 64 MB
给定任一个各位数字不完全相同的 4 位正整数,如果我们先把 4 个数字按非递增排序,再按非递减排序,然后用第 1 个数字减第 2 个数字,将得到一个新的数字。一直重复这样做,我们很快会停在有“数字黑洞”之称的 6174
,这个神奇的数字也叫 Kaprekar 常数。
例如,我们从6767
开始,将得到
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...
现给定任意 4 位正整数,请编写程序演示到达黑洞的过程。
输入格式
输入给出一个
输出格式
如果 N - N = 0000
;否则将计算的每一步在一行内输出,直到 6174
作为差出现,输出格式见样例。注意每个数字按 4
位数格式输出。
输入样例 1
输出样例 1
输入样例 2
输出样例 2
Solution
#include <iostream>
#include <map>
#include <string>
using namespace std;
string division(string s1, string s2) {
int i, m, num = 0;
string s, c;
for (i = 3; i >= 0; i--) {
num += s1[i] - s2[i];
if (num >= 0) {
s += num + '0';
num = 0;
} else if (num < 0) {
num += 10;
s += num + '0';
num = -1;
}
}
for (i = 3; i >= 0; i--) {
c += s[i];
}
return c;
}
string front(string s) {
int i = 0, j = 0;
char temp;
int len = s.size();
for (i = 0; i < 4 - len; i++) {
s.insert(0, "0");
}
for (i = 1; i < 4; i++) {
for (j = 0; j < 4 - i; j++) {
if (s[j] < s[j + 1]) {
temp = s[j];
s[j] = s[j + 1];
s[j + 1] = temp;
}
}
}
return s;
}
string back(string s) {
int i = 0, j = 0;
char temp;
int len = s.size();
for (i = 0; i < 4 - len; i++) {
s.insert(0, "0");
}
for (i = 1; i < 4; i++) {
for (j = 0; j < 4 - i; j++) {
if (s[j] > s[j + 1]) {
temp = s[j];
s[j] = s[j + 1];
s[j + 1] = temp;
}
}
}
return s;
}
int main() {
string s;
int i, j, k;
cin >> s;
if (s[0] == s[1] && s[2] == s[3] && s[1] == s[2]) {
cout << s << " - " << s << " = "
<< "0000\n"; //
} else {
cout << front(s) << " - " << back(s) << " = ";
s = division(front(s), back(s));
cout << s << endl;
while (s != "6174") {
cout << front(s) << " - " << back(s) << " = ";
s = division(front(s), back(s));
cout << s << endl;
}
}
}
Last update: May 4, 2022