1001 害死人不偿命的(3n+1)猜想
Statement
Metadata
- 作者: CHEN, Yue
- 单位: 浙江大学
- 代码长度限制: 16 KB
- 时间限制: 400 ms
- 内存限制: 64 MB
卡拉兹(Callatz)猜想:
对任何一个正整数
我们今天的题目不是证明卡拉兹猜想,而是对给定的任一不超过 1000 的正整数
输入格式
每个测试输入包含 1 个测试用例,即给出正整数
输出格式
输出从
输入样例
输出样例
Solution
#include <stdio.h>
int main() {
int n;
scanf("%d", &n);
int total = 0;
while (n != 1) {
if (n % 2 == 0) {
n /= 2;
} else {
n = (3 * n + 1) / 2;
}
total++;
}
printf("%d\n", total);
}
Last update: May 4, 2022