Skip to content

1147 Heaps

Statement

Metadata

  • 作者: CHEN, Yue
  • 单位: 浙江大学
  • 代码长度限制: 16 KB
  • 时间限制: 200 ms
  • 内存限制: 64 MB

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification

Each input file contains one test case. For each case, the first line gives two positive integers: M (\le 100), the number of trees to be tested; and N (1 < N \le 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

Solution

#include <bits/stdc++.h>
using namespace std;
const int N = 1e3 + 10;
int n, a[N];
vector<int> vec;

void dfs(int u) {
    if (u > n)
        return;
    dfs(u << 1);
    dfs(u << 1 | 1);
    vec.push_back(a[u]);
}

int main() {
    int _T;
    cin >> _T >> n;
    while (_T--) {
        int l = 0, g = 0;
        for (int i = 1; i <= n; ++i) {
            scanf("%d", a + i);
            if (i > 1) {
                if (a[i] > a[i >> 1])
                    ++l;
                else
                    ++g;
            }
        }
        if (l && g)
            puts("Not Heap");
        else if (l)
            puts("Min Heap");
        else
            puts("Max Heap");
        vec.clear();
        dfs(1);
        for (int i = 0; i < n; ++i) printf("%d%c", vec[i], " \n"[i == n - 1]);
    }
    return 0;
}

Last update: May 4, 2022
Back to top