1117 Eddington Number
Statement
Metadata
- 作者: CHEN, Yue
- 单位: 浙江大学
- 代码长度限制: 16 KB
- 时间限制: 250 ms
- 内存限制: 64 MB
British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number",
Now given everyday's distances that one rides for
Input Specification
Each input file contains one test case. For each case, the first line gives a positive integer
Output Specification
For each case, print in a line the Eddington number for these
Sample Input
Sample Output
Solution
#include <bits/stdc++.h>
using namespace std;
const int N = 1e5 + 10;
int n, a[N];
int main() {
while (scanf("%d", &n) != EOF) {
for (int i = 1; i <= n; ++i) {
scanf("%d", a + i);
}
sort(a + 1, a + 1 + n, [&](int x, int y) {
return x > y;
});
int res = 0;
for (int i = 1; i <= n; ++i) {
if (a[i] > i) {
res = i;
}
}
printf("%d\n", res);
}
return 0;
}
Last update: May 4, 2022