1101 Quick Sort
Statement
Metadata
- 作者: CAO, Peng
- 单位: Google
- 代码长度限制: 16 KB
- 时间限制: 200 ms
- 内存限制: 64 MB
There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given
For example, given
- 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
- 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
- 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
- and for the similar reason, 4 and 5 could also be the pivot.
Hence in total there are 3 pivot candidates.
Input Specification
Each input file contains one test case. For each case, the first line gives a positive integer
Output Specification
For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.
Sample Input
Sample Output
Solution
#include <bits/stdc++.h>
using namespace std;
const int N = 1e5 + 10;
int n, a[N], f[N], g[N];
int main() {
while (scanf("%d", &n) != EOF) {
for (int i = 1; i <= n; ++i) scanf("%d", a + i);
f[0] = -1, g[n + 1] = 1e9;
for (int i = 1; i <= n; ++i) {
f[i] = max(f[i - 1], a[i]);
}
for (int i = n; i >= 1; --i) {
g[i] = min(g[i + 1], a[i]);
}
int res = 0;
vector<int> vec;
for (int i = 1; i <= n; ++i) {
if (f[i - 1] < a[i] && g[i + 1] > a[i])
++res, vec.push_back(a[i]);
}
printf("%d\n", res);
for (int i = 0; i < res; ++i) printf("%d%c", vec[i], " \n"[i == res - 1]);
if (!res)
cout << endl;
}
return 0;
}