1041 Be Unique
Statement
Metadata
- 作者: CHEN, Yue
- 单位: 浙江大学
- 代码长度限制: 16 KB
- 时间限制: 200 ms
- 内存限制: 64 MB
Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [
Input Specification
Each input file contains one test case. Each case contains a line which begins with a positive integer
Output Specification
For each test case, print the winning number in a line. If there is no winner, print None
instead.
Sample Input 1
Sample Output 1
Sample Input 2
Sample Output 2
Solution
#include <ctype.h>
#include <algorithm>
#include <climits>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <ctime>
#include <deque>
#include <iomanip>
#include <iostream>
#include <limits>
#include <map>
#include <numeric>
#include <queue>
#include <set>
#include <sstream>
#include <stack>
#include <string>
#include <vector>
#define CLR(a) memset(a, 0, sizeof(a))
#define pb push_back
using namespace std;
typedef long long ll;
typedef long double ld;
typedef unsigned long long ull;
typedef pair<int, int> pii;
typedef pair<ll, ll> pll;
typedef pair<string, int> psi;
typedef pair<string, string> pss;
const double PI = 3.14159265358979323846264338327;
const double E = exp(1);
const double eps = 1e-30;
const int INF = 0x3f3f3f3f;
const int maxn = 1e5 + 5;
const int MOD = 1e9 + 7;
int main() {
int n, num;
scanf("%d", &n);
map<int, int> m;
vector<int> ans;
for (int i = 0; i < n; i++) {
scanf("%d", &num);
m[num]++;
if (m[num] == 1)
ans.pb(num);
}
vector<int>::iterator it;
for (it = ans.begin(); it != ans.end(); it++) {
if (m[*it] == 1) {
printf("%d\n", *it);
break;
}
}
if (it == ans.end())
printf("None\n");
}
Last update: May 4, 2022