Skip to content

1041 Be Unique

Statement

Metadata

  • 作者: CHEN, Yue
  • 单位: 浙江大学
  • 代码长度限制: 16 KB
  • 时间限制: 200 ms
  • 内存限制: 64 MB

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 10^4]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification

Each input file contains one test case. Each case contains a line which begins with a positive integer N (\le 10^5) and then followed by N bets. The numbers are separated by a space.

Output Specification

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1

7 5 31 5 88 67 88 17

Sample Output 1

31

Sample Input 2

5 888 666 666 888 888

Sample Output 2

None

Solution

#include <ctype.h>
#include <algorithm>
#include <climits>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <ctime>
#include <deque>
#include <iomanip>
#include <iostream>
#include <limits>
#include <map>
#include <numeric>
#include <queue>
#include <set>
#include <sstream>
#include <stack>
#include <string>
#include <vector>

#define CLR(a) memset(a, 0, sizeof(a))
#define pb push_back

using namespace std;
typedef long long ll;
typedef long double ld;
typedef unsigned long long ull;
typedef pair<int, int> pii;
typedef pair<ll, ll> pll;
typedef pair<string, int> psi;
typedef pair<string, string> pss;

const double PI = 3.14159265358979323846264338327;
const double E = exp(1);
const double eps = 1e-30;

const int INF = 0x3f3f3f3f;
const int maxn = 1e5 + 5;
const int MOD = 1e9 + 7;

int main() {
    int n, num;
    scanf("%d", &n);
    map<int, int> m;
    vector<int> ans;
    for (int i = 0; i < n; i++) {
        scanf("%d", &num);
        m[num]++;
        if (m[num] == 1)
            ans.pb(num);
    }
    vector<int>::iterator it;
    for (it = ans.begin(); it != ans.end(); it++) {
        if (m[*it] == 1) {
            printf("%d\n", *it);
            break;
        }
    }
    if (it == ans.end())
        printf("None\n");
}

Last update: May 4, 2022
Back to top