Skip to content

1028 List Sorting

Statement

Metadata

  • 作者: CHEN, Yue
  • 单位: 浙江大学
  • 代码长度限制: 16 KB
  • 时间限制: 400 ms
  • 内存限制: 64 MB

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification

Each input file contains one test case. For each case, the first line contains two integers N (\le 10^5) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 9

Sample Output 3

000002 James 9
000001 Zoe 60
000007 James 85
000010 Amy 90

鸣谢用户 wangzhj 补充数据!

Solution

#include <ctype.h>
#include <algorithm>
#include <climits>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <ctime>
#include <deque>
#include <iomanip>
#include <iostream>
#include <limits>
#include <map>
#include <numeric>
#include <queue>
#include <set>
#include <sstream>
#include <stack>
#include <string>
#include <vector>

#define CLR(a) memset(a, 0, sizeof(a))
#define pb push_back

using namespace std;
typedef long long ll;
typedef long double ld;
typedef unsigned long long ull;
typedef pair<int, int> pii;
typedef pair<ll, ll> pll;
typedef pair<string, int> psi;
typedef pair<string, string> pss;

const double PI = 3.14159265358979323846264338327;
const double E = exp(1);
const double eps = 1e-30;

const int INF = 0x3f3f3f3f;
const int maxn = 1e5 + 5;
const int MOD = 1e9 + 7;

struct Node {
    int id, g;
    char name[10];
} a[maxn];

bool comp_1(Node x, Node y) {
    return x.id < y.id;
}

bool comp_2(Node x, Node y) {
    if (strcmp(x.name, y.name) == 0)
        return x.id < y.id;
    return strcmp(x.name, y.name) > 0 ? 0 : 1;
}

bool comp_3(Node x, Node y) {
    if (x.g == y.g)
        return x.id < y.id;
    return x.g < y.g;
}

int main() {
    int n, c;
    scanf("%d%d", &n, &c);
    for (int i = 0; i < n; i++) scanf("%d%s%d", &a[i].id, &a[i].name, &a[i].g);
    if (c == 1)
        sort(a, a + n, comp_1);
    else if (c == 2)
        sort(a, a + n, comp_2);
    else if (c == 3)
        sort(a, a + n, comp_3);
    for (int i = 0; i < n; i++) printf("%06d %s %d\n", a[i].id, a[i].name, a[i].g);
}

Last update: May 4, 2022
Back to top