1027 Colors in Mars
Statement
Metadata
- 作者: CHEN, Yue
- 单位: 浙江大学
- 代码长度限制: 16 KB
- 时间限制: 400 ms
- 内存限制: 64 MB
People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red
, the middle 2 digits for Green
, and the last 2 digits for Blue
. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.
Input Specification
Each input file contains one test case which occupies a line containing the three decimal color values.
Output Specification
For each test case you should output the Mars RGB value in the following format: first output #
, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0
to its left.
Sample Input
Sample Output
Solution
#include <bits/stdc++.h>
using namespace std;
string tran(int x) {
int a, b;
a = x % 13;
x /= 13;
b = x % 13;
string s = "";
if (b <= 9)
s += b + '0';
else
s += 'A' + b - 10;
if (a <= 9)
s += a + '0';
else
s += 'A' + a - 10;
return s;
}
int main() {
int a, b, c;
cin >> a >> b >> c;
cout << "#" << tran(a) << tran(b) << tran(c) << endl;
}