Skip to content

1008 Elevator

Statement

Metadata

  • 作者: CHEN, Yue
  • 单位: 浙江大学
  • 代码长度限制: 16 KB
  • 时间限制: 400 ms
  • 内存限制: 64 MB

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification

For each test case, print the total time on a single line.

Sample Input

3 2 3 1

Sample Output

41

Solution

#include <bits/stdc++.h>
using namespace std;
int main() {
    int N, stay = 0, t, i, total = 0;
    cin >> N;
    for (i = 0; i < N; i++) {
        cin >> t;
        if (t == stay)
            total += 5;
        else if (t > stay)
            total += (t - stay) * 6 + 5;
        else if (t < stay)
            total += (stay - t) * 4 + 5;
        stay = t;
    }
    cout << total << endl;
}

Last update: May 4, 2022
Back to top