L3-008 喊山
Statement
Metadata
- 作者: 陈越
- 单位: 浙江大学
- 代码长度限制: 16 KB
- 时间限制: 150 ms
- 内存限制: 64 MB
喊山,是人双手围在嘴边成喇叭状,对着远方高山发出“喂—喂喂—喂喂喂……”的呼唤。呼唤声通过空气的传递,回荡于深谷之间,传送到人们耳中,发出约定俗成的“讯号”,达到声讯传递交流的目的。原来它是彝族先民用来求援呼救的“讯号”,慢慢地人们在生活实践中发现了它的实用价值,便把它作为一种交流工具世代传袭使用。(图文摘自:http://news.xrxxw.com/newsshow-8018.html)
一个山头呼喊的声音可以被临近的山头同时听到。题目假设每个山头最多有两个能听到它的临近山头。给定任意一个发出原始信号的山头,本题请你找出这个信号最远能传达到的地方。
输入格式
输入第一行给出3个正整数n
、m
和k
,其中n
(n
编号)。接下来的m
行,每行给出2个不超过n
的正整数,数字间用空格分开,分别代表可以听到彼此的两个山头的编号。这里保证每一对山头只被输入一次,不会有重复的关系输入。最后一行给出k
(n
的正整数,数字间用空格分开,代表需要查询的山头的编号。
输出格式
依次对于输入中的每个被查询的山头,在一行中输出其发出的呼喊能够连锁传达到的最远的那个山头。注意:被输出的首先必须是被查询的个山头能连锁传到的。若这样的山头不只一个,则输出编号最小的那个。若此山头的呼喊无法传到任何其他山头,则输出0。
输入样例
输出样例
Tutorial
思路:
- 因为每个山头最多有两个能听到它的临近山头
- 那么我们就可以给每个山头都分配最多两个子儿子
- 然后再从儿子往下找
- 一层一层往下找如果找的元素之前已经出现过, 这个就不压入队列
- 直到最后队列为空, 输出当层编号最小的那个
Solution
#include <ctype.h>
#include <algorithm>
#include <climits>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <ctime>
#include <deque>
#include <iomanip>
#include <iostream>
#include <limits>
#include <map>
#include <numeric>
#include <queue>
#include <set>
#include <sstream>
#include <stack>
#include <string>
#include <vector>
#define CLR(a) memset(a, 0, sizeof(a))
using namespace std;
typedef long long ll;
typedef long double ld;
typedef unsigned long long ull;
typedef pair<int, int> pii;
typedef pair<ll, ll> pll;
typedef pair<string, int> psi;
typedef pair<string, string> pss;
const double PI = 3.14159265358979323846264338327;
const double E = exp(1);
const double eps = 1e-3;
const int INF = 0x3f3f3f3f;
const int maxn = 1e4 + 5;
const int MOD = 1e9 + 7;
int ans;
queue<int> opt;
map<int, int> q, vis;
struct Node {
int l, r;
} w[maxn];
void bfs(int cur) {
int len = opt.size();
int Min = INF;
while (len--) {
int num = opt.front();
opt.pop();
if (num < Min)
Min = num;
if (vis[w[num].l] == 0) {
opt.push(w[num].l);
vis[w[num].l] = 1;
}
if (vis[w[num].r] == 0) {
opt.push(w[num].r);
vis[w[num].r] = 1;
}
}
if (opt.empty()) {
ans = Min;
return;
} else
bfs(cur + 1);
}
int main() {
int n, m, k;
scanf("%d%d%d", &n, &m, &k);
int a, b;
for (int i = 0; i < m; i++) {
scanf("%d%d", &a, &b);
q[a] = 1;
q[b] = 1;
if (w[a].l)
w[a].r = b;
else
w[a].l = b;
if (w[b].l)
w[b].r = a;
else
w[b].l = a;
}
for (int i = 0; i < k; i++) {
scanf("%d", &a);
if (q[a] == 0)
printf("0\n");
else {
vis.clear();
vis[0] = 1;
while (!opt.empty()) opt.pop();
if (w[a].l != 0)
opt.push(w[a].l);
if (w[a].r != 0)
opt.push(w[a].r);
vis[w[a].l] = 1;
vis[w[a].r] = 1;
vis[a] = 1;
bfs(1);
printf("%d\n", ans);
}
}
}
Last update: May 4, 2022