L2-025 分而治之
Statement
Metadata
- 作者: 陈越
- 单位: 浙江大学
- 代码长度限制: 16 KB
- 时间限制: 600 ms
- 内存限制: 64 MB
分而治之,各个击破是兵家常用的策略之一。在战争中,我们希望首先攻下敌方的部分城市,使其剩余的城市变成孤立无援,然后再分头各个击破。为此参谋部提供了若干打击方案。本题就请你编写程序,判断每个方案的可行性。
输入格式
输入在第一行给出两个正整数 N 和 M(均不超过10 000),分别为敌方城市个数(于是默认城市从 1 到 N 编号)和连接两城市的通路条数。随后 M 行,每行给出一条通路所连接的两个城市的编号,其间以一个空格分隔。在城市信息之后给出参谋部的系列方案,即一个正整数 K (
其中 Np
是该方案中计划攻下的城市数量,后面的系列 v[i]
是计划攻下的城市编号。
输出格式
对每一套方案,如果可行就输出YES
,否则输出NO
。
输入样例
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 10
2 4
5
4 10 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2
输出样例
Solution
#include <ctype.h>
#include <algorithm>
#include <climits>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <ctime>
#include <deque>
#include <iomanip>
#include <iostream>
#include <limits>
#include <map>
#include <numeric>
#include <queue>
#include <set>
#include <sstream>
#include <stack>
#include <string>
#include <vector>
#define CLR(a) memset(a, 0, sizeof(a))
#define pb push_back
using namespace std;
typedef long long ll;
typedef long double ld;
typedef unsigned long long ull;
typedef pair<int, int> pii;
typedef pair<ll, ll> pll;
const double PI = acos(-1);
const double E = exp(1);
const double eps = 1e-6;
const int INF = 0x3f3f3f3f;
const int maxn = 1e4 + 5;
const int MOD = 1e9 + 7;
vector<int> G[maxn];
int v[maxn];
void init() {
CLR(G);
}
int main() {
int n, m;
scanf("%d%d", &n, &m);
int x, y;
for (int i = 0; i < m; i++) {
scanf("%d%d", &x, &y);
G[x].pb(y);
G[y].pb(x);
}
int T;
scanf("%d", &T);
while (T--) {
int k;
scanf("%d", &k);
map<int, int> M;
for (int j = 0; j < k; j++) {
int num;
scanf("%d", &num);
M[num] = 1;
}
int flag = 1;
vector<int>::iterator it;
for (int i = 0; i < n; i++) {
if (M[i])
continue;
for (it = G[i].begin(); it != G[i].end(); it++) {
if (M[*it] == 0) {
flag = 0;
break;
}
}
}
printf("%s\n", flag ? "YES" : "NO");
}
}
Last update: May 4, 2022