Skip to content

L2-024 部落

Statement

Metadata

  • 作者: 陈越
  • 单位: 浙江大学
  • 代码长度限制: 16 KB
  • 时间限制: 150 ms
  • 内存限制: 64 MB

在一个社区里,每个人都有自己的小圈子,还可能同时属于很多不同的朋友圈。我们认为朋友的朋友都算在一个部落里,于是要请你统计一下,在一个给定社区中,到底有多少个互不相交的部落?并且检查任意两个人是否属于同一个部落。

输入格式

输入在第一行给出一个正整数N\le 10^4),是已知小圈子的个数。随后N行,每行按下列格式给出一个小圈子里的人:

K P[1] P[2] \cdots P[K]

其中K是小圈子里的人数,P[i]i=1, \cdots , K)是小圈子里每个人的编号。这里所有人的编号从1开始连续编号,最大编号不会超过10^4

之后一行给出一个非负整数Q\le 10^4),是查询次数。随后Q行,每行给出一对被查询的人的编号。

输出格式

首先在一行中输出这个社区的总人数、以及互不相交的部落的个数。随后对每一次查询,如果他们属于同一个部落,则在一行中输出Y,否则输出N

输入样例

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

输出样例

10 2
Y
N

Solution

#include <ctype.h>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <deque>
#include <iostream>
#include <map>
#include <numeric>
#include <queue>
#include <set>
#include <sstream>
#include <stack>
#include <string>
#include <vector>
using namespace std;

typedef long long LL;
const double PI = 3.14159265358979323846264338327;
const double E = 2.718281828459;
const double eps = 1e-6;
const int MAXN = 0x3f3f3f3f;
const int MINN = 0xc0c0c0c0;
const int maxn = 1e4 + 5;
const int MOD = 1e9 + 7;
int pre[maxn], arr[maxn];
int find(int x) {
    int r = x;
    while (pre[r] != r) r = pre[r];
    pre[x] = r;
    return r;
}
void join(int x, int y) {
    int fx = find(x), fy = find(y);
    if (x != fy)
        pre[fx] = fy;
}

int main() {
    int n, mi;
    int num, vis;
    cin >> n;
    int i, j, k = 0;
    map<int, int> q;
    map<int, int> m;
    map<int, int> flag;
    flag.clear();
    m.clear();
    q.clear();
    for (i = 0; i < maxn; i++) pre[i] = i;
    for (i = 0; i < n; i++) {
        cin >> mi;
        cin >> num;
        flag[num] = 1;
        for (j = 1; j < mi; j++) {
            scanf("%d", &vis);
            join(num, vis);
            flag[vis] = 1;
        }
    }
    map<int, int>::iterator it;
    for (it = flag.begin(); it != flag.end(); it++) arr[k++] = it->first;
    int len = k;
    for (i = 0; i < k; i++) q[find(arr[i])] = 1;
    cout << len << " " << q.size() << endl;
    scanf("%d", &mi);
    for (i = 0; i < mi; i++) {
        int a, b;
        scanf("%d%d", &a, &b);
        if (find(a) == find(b))
            printf("Y\n");
        else
            printf("N\n");
    }
}

Last update: May 4, 2022
Back to top