Skip to content

L2-020 功夫传人

Statement

Metadata

  • 作者: 陈越
  • 单位: 浙江大学
  • 代码长度限制: 16 KB
  • 时间限制: 400 ms
  • 内存限制: 64 MB

一门武功能否传承久远并被发扬光大,是要看缘分的。一般来说,师傅传授给徒弟的武功总要打个折扣,于是越往后传,弟子们的功夫就越弱…… 直到某一支的某一代突然出现一个天分特别高的弟子(或者是吃到了灵丹、挖到了特别的秘笈),会将功夫的威力一下子放大N倍 —— 我们称这种弟子为“得道者”。

这里我们来考察某一位祖师爷门下的徒子徒孙家谱:假设家谱中的每个人只有1位师傅(除了祖师爷没有师傅);每位师傅可以带很多徒弟;并且假设辈分严格有序,即祖师爷这门武功的每个第i代传人只能在第i-1代传人中拜1个师傅。我们假设已知祖师爷的功力值为Z,每向下传承一代,就会减弱r%,除非某一代弟子得道。现给出师门谱系关系,要求你算出所有得道者的功力总值。

输入格式

输入在第一行给出3个正整数,分别是:N\le 10^5)——整个师门的总人数(于是每个人从0到N-1编号,祖师爷的编号为0);Z——祖师爷的功力值(不一定是整数,但起码是正数);r ——每传一代功夫所打的折扣百分比值(不超过100的正数)。接下来有N行,第i行(i=0, \cdots , N-1)描述编号为i的人所传的徒弟,格式为:

K_i ID[1] ID[2] \cdots ID[K_i]

其中K_i是徒弟的个数,后面跟的是各位徒弟的编号,数字间以空格间隔。K_i为零表示这是一位得道者,这时后面跟的一个数字表示其武功被放大的倍数。

输出格式

在一行中输出所有得道者的功力总值,只保留其整数部分。题目保证输入和正确的输出都不超过10^{10}

输入样例

10 18.0 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

输出样例

404

Solution

#include <ctype.h>
#include <algorithm>
#include <climits>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <ctime>
#include <deque>
#include <iomanip>
#include <iostream>
#include <limits>
#include <map>
#include <numeric>
#include <queue>
#include <set>
#include <sstream>
#include <stack>
#include <string>
#include <vector>

#define CLR(a) memset(a, 0, sizeof(a))
#define pb push_back

using namespace std;
typedef long long ll;
typedef long double ld;
typedef unsigned long long ull;
typedef pair<int, int> pii;
typedef pair<ll, ll> pll;
typedef pair<string, int> psi;
typedef pair<string, string> pss;

const double PI = 3.14159265358979323846264338327;
const double E = exp(1);
const double eps = 1e-6;

const int INF = 0x3f3f3f3f;
const int maxn = 1e5 + 5;
const int MOD = 1e9 + 7;

ll n;

double z, r;

struct Node {
    int tot;
    vector<int> v;
} temp;

ld ans = 0.0;

vector<Node> d, da;

void dfs(int x, int cur) {
    if (d[x].tot == 0) {
        ans += z * pow(r, cur) * d[x].v[0];
        return;
    }
    vector<int>::iterator it;
    for (it = d[x].v.begin(); it != d[x].v.end(); it++) {
        dfs((*it), cur + 1);
    }
}

int main() {
    int num;
    scanf("%lld%lf%lf", &n, &z, &r);
    r = (100 - r) * 1.0 / 100;
    for (int i = 0; i < n; i++) {
        scanf("%d", &temp.tot);
        temp.v.clear();
        if (temp.tot == 0) {
            scanf("%d", &num);
            temp.v.pb(num);
        }
        for (int j = 0; j < temp.tot; j++) {
            scanf("%d", &num);
            temp.v.pb(num);
        }
        d.pb(temp);
    }
    dfs(0, 0);
    printf("%.0Lf\n", ans - 0.5);
}

Last update: May 4, 2022
Back to top