Skip to content

L2-013 红色警报

Statement

Metadata

  • 作者: 陈越
  • 单位: 浙江大学
  • 代码长度限制: 16 KB
  • 时间限制: 400 ms
  • 内存限制: 64 MB

战争中保持各个城市间的连通性非常重要。本题要求你编写一个报警程序,当失去一个城市导致国家被分裂为多个无法连通的区域时,就发出红色警报。注意:若该国本来就不完全连通,是分裂的k个区域,而失去一个城市并不改变其他城市之间的连通性,则不要发出警报。

输入格式

输入在第一行给出两个整数N(0 < N \le 500)和M\le 5000),分别为城市个数(于是默认城市从0到N-1编号)和连接两城市的通路条数。随后M行,每行给出一条通路所连接的两个城市的编号,其间以1个空格分隔。在城市信息之后给出被攻占的信息,即一个正整数K和随后的K个被攻占的城市的编号。

注意:输入保证给出的被攻占的城市编号都是合法的且无重复,但并不保证给出的通路没有重复。

输出格式

对每个被攻占的城市,如果它会改变整个国家的连通性,则输出Red Alert: City k is lost!,其中k是该城市的编号;否则只输出City k is lost.即可。如果该国失去了最后一个城市,则增加一行输出Game Over.

输入样例

5 4
0 1
1 3
3 0
0 4
5
1 2 0 4 3

输出样例

City 1 is lost.
City 2 is lost.
Red Alert: City 0 is lost!
City 4 is lost.
City 3 is lost.
Game Over.

Solution

#include <ctype.h>
#include <algorithm>
#include <climits>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <ctime>
#include <deque>
#include <iomanip>
#include <iostream>
#include <limits>
#include <map>
#include <numeric>
#include <queue>
#include <set>
#include <sstream>
#include <stack>
#include <string>
#include <vector>

#define CLR(a) memset(a, 0, sizeof(a))
#define pb push_back

using namespace std;
typedef long long ll;
typedef long double ld;
typedef unsigned long long ull;
typedef pair<int, int> pii;
typedef pair<ll, ll> pll;

const double PI = 3.14159265358979323846264338327;
const double E = exp(1);
const double eps = 1e-6;

const int INF = 0x3f3f3f3f;
const int maxn = 5e2 + 5;
const int MOD = 1e9 + 7;

int G[maxn][maxn];
int v[maxn];

int n, m;

void dfs(int x) {
    v[x] = 1;
    for (int i = 0; i < n; i++) {
        if (v[i] == 0 && G[x][i] == 1)
            dfs(i);
    }
}

void init() {
    CLR(G);
    CLR(v);
}

int main() {
    scanf("%d%d", &n, &m);
    int x, y;
    for (int i = 0; i < m; i++) {
        scanf("%d%d", &x, &y);
        G[x][y] = G[y][x] = 1;
    }
    int fin = 0;
    for (int i = 0; i < n; i++) {
        if (v[i] == 0) {
            dfs(i);
            fin++;
        }
    }
    int k;
    scanf("%d", &k);
    for (int i = 0; i < k; i++) {
        scanf("%d", &x);
        for (int j = 0; j < n; j++) G[x][j] = G[j][x] = 0;
        int temp = 0;
        CLR(v);
        for (int j = 0; j < n; j++) {
            if (v[j] == 0) {
                dfs(j);
                temp++;
            }
        }
        if (temp > fin + 1)
            printf("Red Alert: City %d is lost!\n", x);
        else
            printf("City %d is lost.\n", x);
        fin = temp;
        if (i == n - 1)
            printf("Game Over.\n");
    }
}

Last update: May 4, 2022
Back to top