Skip to content

L2-010 排座位

Statement

Metadata

  • 作者: 陈越
  • 单位: 浙江大学
  • 代码长度限制: 16 KB
  • 时间限制: 150 ms
  • 内存限制: 64 MB

布置宴席最微妙的事情,就是给前来参宴的各位宾客安排座位。无论如何,总不能把两个死对头排到同一张宴会桌旁!这个艰巨任务现在就交给你,对任何一对客人,请编写程序告诉主人他们是否能被安排同席。

输入格式

输入第一行给出3个正整数:N\le100),即前来参宴的宾客总人数,则这些人从1到N编号;M为已知两两宾客之间的关系数;K为查询的条数。随后M行,每行给出一对宾客之间的关系,格式为:宾客1 宾客2 关系,其中关系为1表示是朋友,-1表示是死对头。注意两个人不可能既是朋友又是敌人。最后K行,每行给出一对需要查询的宾客编号。

这里假设朋友的朋友也是朋友。但敌人的敌人并不一定就是朋友,朋友的敌人也不一定是敌人。只有单纯直接的敌对关系才是绝对不能同席的。

输出格式

对每个查询输出一行结果:如果两位宾客之间是朋友,且没有敌对关系,则输出No problem;如果他们之间并不是朋友,但也不敌对,则输出OK;如果他们之间有敌对,然而也有共同的朋友,则输出OK but...;如果他们之间只有敌对关系,则输出No way

输入样例

7 8 4
5 6 1
2 7 -1
1 3 1
3 4 1
6 7 -1
1 2 1
1 4 1
2 3 -1
3 4
5 7
2 3
7 2

输出样例

No problem
OK
OK but...
No way

Solution

#include <ctype.h>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <deque>
#include <iomanip>
#include <iostream>
#include <map>
#include <numeric>
#include <queue>
#include <set>
#include <sstream>
#include <stack>
#include <string>
#include <vector>

using namespace std;
typedef long long LL;

const double PI = 3.14159265358979323846264338327;
const double E = 2.718281828459;
const double eps = 1e-6;

const int MAXN = 0x3f3f3f3f;
const int MINN = 0xc0c0c0c0;
const int maxn = 1e2 + 5;
const int MOD = 1e9 + 7;

int pre[maxn];

struct Node {
    vector<int> v;
};

map<int, Node> M;

int find(int x) {
    int r = x;
    while (pre[r] != r) r = pre[r];
    pre[x] = r;
    return r;
}

void join(int x, int y) {
    int fx = find(x), fy = find(y);
    if (x != fy)
        pre[fx] = fy;
}

bool Hos(int x, int y) {
    vector<int>::iterator it;
    for (it = M[x].v.begin(); it != M[x].v.end(); it++) {
        if ((*it) == y)
            return true;
    }
    return false;
}

int main() {
    int n, m, k;
    scanf("%d%d%d", &n, &m, &k);
    for (int i = 0; i < 2; i++) {
        for (int j = 0; j <= n; j++) pre[j] = j;
    }
    int x, y, flag;
    for (int i = 0; i < m; i++) {
        scanf("%d%d%d", &x, &y, &flag);
        if (flag == 1)
            join(x, y);
        else {
            M[x].v.push_back(y);
            M[y].v.push_back(x);
        }
    }
    for (int i = 0; i < k; i++) {
        scanf("%d%d", &x, &y);
        if (find(x) == find(y)) {
            if (Hos(x, y) == true)
                printf("OK but...\n");
            else
                printf("No problem\n");
        } else {
            if (Hos(x, y) == true)
                printf("No way\n");
            else
                printf("OK\n");
        }
    }
}

Last update: May 4, 2022
Back to top