L2-007 家庭房产
Statement
Metadata
- 作者: 陈越
- 单位: 浙江大学
- 代码长度限制: 16 KB
- 时间限制: 400 ms
- 内存限制: 64 MB
给定每个人的家庭成员和其自己名下的房产,请你统计出每个家庭的人口数、人均房产面积及房产套数。
输入格式
输入第一行给出一个正整数
编号
是每个人独有的一个4位数的编号;父
和母
分别是该编号对应的这个人的父母的编号(如果已经过世,则显示-1
);k
(k
孩子i
是其子女的编号。 输出格式
首先在第一行输出家庭个数(所有有亲属关系的人都属于同一个家庭)。随后按下列格式输出每个家庭的信息:
其中人均值要求保留小数点后3位。家庭信息首先按人均面积降序输出,若有并列,则按成员编号的升序输出。输入样例
10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100
输出样例
Solution
#include <ctype.h>
#include <algorithm>
#include <climits>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <ctime>
#include <deque>
#include <iomanip>
#include <iostream>
#include <limits>
#include <map>
#include <numeric>
#include <queue>
#include <set>
#include <sstream>
#include <stack>
#include <string>
#include <vector>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
typedef pair<int, int> pii;
typedef pair<ll, ll> pll;
const double PI = 3.14159265358979323846264338327;
const double E = 2.718281828459;
const double eps = 1e-6;
const int INF = 0x3f3f3f3f;
const int maxn = 1e6 + 5;
const int MOD = 1e9 + 7;
int pre[10000];
int find(int x) {
while (pre[x] != x) x = pre[x];
return x;
}
void join(int x, int y) {
int fx = find(x), fy = find(y);
if (x != fy)
pre[fx] = fy;
}
struct Node {
int id;
int total;
int tot;
double ave, area;
} temp, q[maxn];
bool comp(Node x, Node y) {
if (fabs(x.area - y.area) < eps)
return x.id < y.id;
return x.area > y.area;
}
int main() {
for (int i = 0; i < 10000; i++) pre[i] = i;
int n;
cin >> n;
map<int, Node> m;
map<int, int> vis;
for (int i = 0; i < n; i++) {
int id, a, b, k;
scanf("%d%d%d%d", &id, &a, &b, &k);
vis[id] = 1;
if (a != -1) {
join(id, a);
vis[a] = 1;
}
if (b != -1) {
join(id, b);
vis[b] = 1;
}
for (int j = 0; j < k; j++) {
scanf("%d", &a);
if (a != -1) {
join(id, a);
vis[a] = 1;
}
}
scanf("%d%d", &a, &b);
m[id].id = id;
m[id].tot = a;
m[id].area = b;
}
map<int, int>::iterator it, iter;
int count = 0;
for (it = vis.begin(); it != vis.end(); it++) {
temp.id = 0;
temp.tot = 0;
temp.tot = 0;
temp.ave = 0.0;
temp.area = 0.0;
if (it->second == 1) {
it->second = 0;
int flag = find(it->first);
temp.id = it->first;
temp.tot += m[it->first].tot;
temp.area += m[it->first].area;
temp.total = 1;
for (iter = it, iter++; iter != vis.end(); iter++) {
if (iter->second == 1 && flag == find(iter->first)) {
iter->second = 0;
if (m[iter->first].id == iter->first) {
if (iter->first < temp.id)
temp.id = iter->first;
temp.tot += m[iter->first].tot;
temp.area += m[iter->first].area;
}
temp.total++;
}
}
temp.ave = temp.tot * 1.0 / temp.total;
temp.area /= temp.total;
q[count++] = temp;
}
}
sort(q, q + count, comp);
printf("%d\n", count);
for (int i = 0; i < count; i++) {
printf("%04d %d %.3lf %.3lf\n", q[i].id, q[i].total, q[i].ave, q[i].area);
}
}
Last update: May 4, 2022