L2-003 月饼
Statement
Metadata
- 作者: 陈越
- 单位: 浙江大学
- 代码长度限制: 16 KB
- 时间限制: 150 ms
- 内存限制: 64 MB
月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。
注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有 3 种月饼,其库存量分别为 18、15、10 万吨,总售价分别为 75、72、45 亿元。如果市场的最大需求量只有 20 万吨,那么我们最大收益策略应该是卖出全部 15 万吨第 2 种月饼、以及 5 万吨第 3 种月饼,获得 72 + 45/2 = 94.5(亿元)。
输入格式
每个输入包含一个测试用例。每个测试用例先给出一个不超过 1000 的正整数
输出格式
对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后 2 位。
输入样例
输出样例
Solution
#include <ctype.h>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <deque>
#include <iomanip>
#include <iostream>
#include <map>
#include <numeric>
#include <queue>
#include <set>
#include <sstream>
#include <stack>
#include <string>
#include <vector>
using namespace std;
typedef long long LL;
const double PI = 3.14159265358979323846264338327;
const double E = 2.718281828459;
const double eps = 1e-6;
const int MAXN = 0x3f3f3f3f;
const int MINN = 0xc0c0c0c0;
const int maxn = 1e3 + 5;
const int MOD = 1e9 + 7;
struct Node {
double x, y, ave;
} q[maxn];
bool comp(Node x, Node y) {
return x.ave > y.ave;
}
int main() {
int n, d;
scanf("%d%d", &n, &d);
memset(q, 0, sizeof(q));
for (int i = 0; i < n; i++) scanf("%lf", &q[i].x);
for (int i = 0; i < n; i++) {
scanf("%lf", &q[i].y);
q[i].ave = q[i].y / q[i].x;
}
sort(q, q + n, comp);
long double sum = 0.0;
for (int i = 0; i < n; i++) {
if (d >= q[i].x) {
sum += q[i].y;
d -= q[i].x;
} else {
sum += q[i].ave * d;
break;
}
}
printf("%.2Lf\n", sum);
}
Last update: May 4, 2022