Skip to content

L1-054 福到了

Statement

Metadata

  • 作者: 陈越
  • 单位: 浙江大学
  • 代码长度限制: 16 KB
  • 时间限制: 400 ms
  • 内存限制: 64 MB

“福”字倒着贴,寓意“福到”。不论到底算不算民俗,本题且请你编写程序,把各种汉字倒过来输出。这里要处理的每个汉字是由一个 N \times N 的网格组成的,网格中的元素或者为字符 @ 或者为空格。而倒过来的汉字所用的字符由裁判指定。

输入格式

输入在第一行中给出倒过来的汉字所用的字符、以及网格的规模 N (不超过100的正整数),其间以 1 个空格分隔;随后 N 行,每行给出 N 个字符,或者为 @ 或者为空格。

输出格式

输出倒置的网格,如样例所示。但是,如果这个字正过来倒过去是一样的,就先输出bu yong dao le,然后再用输入指定的字符将其输出。

输入样例 1

$ 9
 @  @@@@@
@@@  @@@ 
 @   @ @ 
@@@  @@@ 
@@@ @@@@@
@@@ @ @ @
@@@ @@@@@
 @  @ @ @
 @  @@@@@

输出样例 1

$$$  $ 
$ $ $  $ 
$$$ $$
$ $ $ $$
$$$ $$
 $$  $$
 $ $   $ 
 $$  $$
$$$  $ 

输入样例 2

& 3
@@@
 @ 
@@@

输出样例 2

bu yong dao le
&&&
 & 
&&&

Solution

#include <ctype.h>
#include <algorithm>
#include <climits>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <ctime>
#include <deque>
#include <iomanip>
#include <iostream>
#include <limits>
#include <map>
#include <numeric>
#include <queue>
#include <set>
#include <sstream>
#include <stack>
#include <string>
#include <vector>

#define CLR(a) memset(a, 0, sizeof(a))
#define pb push_back

using namespace std;
typedef long long ll;
typedef long double ld;
typedef unsigned long long ull;
typedef pair<int, int> pii;
typedef pair<ll, ll> pll;

const double PI = 3.14159265358979323846264338327;
const double E = exp(1);
const double eps = 1e-6;

const int INF = 0x3f3f3f3f;
const int maxn = 1e2 + 5;
const int MOD = 1e9 + 7;

string in[maxn], tran[maxn];

string Reverse(string s) {
    string ans = "";
    int len = s.size();
    for (int i = len - 1; i >= 0; i--) ans += s[i];
    return ans;
}

int main() {
    char c;
    int n;
    scanf(" %c%d", &c, &n);
    getchar();
    for (int i = 0; i < n; i++) {
        getline(cin, in[i]);
        tran[n - 1 - i] = Reverse(in[i]);
    }
    int flag = 1;
    for (int i = 0; i < n; i++) {
        if (in[i] != tran[i]) {
            flag = 0;
            break;
        }
    }
    if (flag)
        printf("bu yong dao le\n");
    for (int i = 0; i < n; i++) {
        int len = tran[i].size();
        for (int j = 0; j < len; j++) {
            if (tran[i][j] != ' ')
                printf("%c", c);
            else
                printf(" ");
        }
        printf("\n");
    }
}

Last update: May 4, 2022
Back to top