Skip to content

L1-050 倒数第N个字符串

Statement

Metadata

  • 作者: 陈越
  • 单位: 浙江大学
  • 代码长度限制: 16 KB
  • 时间限制: 400 ms
  • 内存限制: 64 MB

给定一个完全由小写英文字母组成的字符串等差递增序列,该序列中的每个字符串的长度固定为 L,从 L 个 a 开始,以 1 为步长递增。例如当 L 为 3 时,序列为 { aaa, aab, aac, …, aaz, aba, abb, …, abz, …, zzz }。这个序列的倒数第27个字符串就是 zyz。对于任意给定的 L,本题要求你给出对应序列倒数第 N 个字符串。

输入格式

输入在一行中给出两个正整数 L(2 \le L \le 6)和 N(\le 10^5)。

输出格式

在一行中输出对应序列倒数第 N 个字符串。题目保证这个字符串是存在的。

输入样例

3 7417

输出样例

pat

Solution

#include <ctype.h>
#include <algorithm>
#include <climits>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <ctime>
#include <deque>
#include <iomanip>
#include <iostream>
#include <limits>
#include <map>
#include <numeric>
#include <queue>
#include <set>
#include <sstream>
#include <stack>
#include <string>
#include <vector>

#define CLR(a) memset(a, 0, sizeof(a))
#define pb push_back

using namespace std;
typedef long long ll;
typedef long double ld;
typedef unsigned long long ull;
typedef pair<int, int> pii;
typedef pair<ll, ll> pll;

const double PI = 3.14159265358979323846264338327;
const double E = exp(1);
const double eps = 1e-6;

const int INF = 0x3f3f3f3f;
const int maxn = 1e5 + 5;
const int MOD = 1e9 + 7;

int main() {
    map<int, char> m;
    for (int i = 'z', j = 0; i >= 'a'; i--, j++) m[j] = i;
    int a, b;
    scanf("%d%d", &a, &b);
    b--;
    int ans[6];
    CLR(ans);
    for (int i = 0; b; i++) {
        ans[i] = b % 26;
        b /= 26;
    }
    string s = "";
    for (int i = 0; i < a; i++) s += m[ans[i]];
    reverse(s.begin(), s.end());
    cout << s << endl;
}

Last update: May 4, 2022
Back to top