Skip to content

L1-043 阅览室

Statement

Metadata

  • 作者: 陈越
  • 单位: 浙江大学
  • 代码长度限制: 16 KB
  • 时间限制: 400 ms
  • 内存限制: 64 MB

天梯图书阅览室请你编写一个简单的图书借阅统计程序。当读者借书时,管理员输入书号并按下S键,程序开始计时;当读者还书时,管理员输入书号并按下E键,程序结束计时。书号为不超过1000的正整数。当管理员将0作为书号输入时,表示一天工作结束,你的程序应输出当天的读者借书次数和平均阅读时间。

注意:由于线路偶尔会有故障,可能出现不完整的纪录,即只有S没有E,或者只有E没有S的纪录,系统应能自动忽略这种无效纪录。另外,题目保证书号是书的唯一标识,同一本书在任何时间区间内只可能被一位读者借阅。

输入格式

输入在第一行给出一个正整数N\le 10),随后给出N天的纪录。每天的纪录由若干次借阅操作组成,每次操作占一行,格式为:

书号([1, 1000]内的整数) 键值SE发生时间hh:mm,其中hh是[0,23]内的整数,mm是[0, 59]内整数)

每一天的纪录保证按时间递增的顺序给出。

输出格式

对每天的纪录,在一行中输出当天的读者借书次数和平均阅读时间(以分钟为单位的精确到个位的整数时间)。

输入样例

3
1 S 08:10
2 S 08:35
1 E 10:00
2 E 13:16
0 S 17:00
0 S 17:00
3 E 08:10
1 S 08:20
2 S 09:00
1 E 09:20
0 E 17:00

输出样例

2 196
0 0
1 60

Solution

#include <ctype.h>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <deque>
#include <iostream>
#include <map>
#include <numeric>
#include <queue>
#include <set>
#include <sstream>
#include <stack>
#include <string>
#include <vector>

using namespace std;
typedef long long LL;

const double PI = 3.14159265358979323846264338327;
const double E = 2.718281828459;
const double eps = 1e-6;

const int MAXN = 0x3f3f3f3f;
const int MINN = 0xc0c0c0c0;
const int maxn = 1e5 + 5;
const int MOD = 1e9 + 7;

struct node {
    int time;
    int flag;
};

int main() {
    int t;
    cin >> t;
a:
    while (t--) {
        map<string, node> m;
        m.clear();
        string ID;
        char vis;
        int h, mins;
        int ans = 0;
        int time = 0;
        while (cin >> ID) {
            scanf(" %c %02d:%02d", &vis, &h, &mins);
            if (ID == "0") {
                if (ans > 0)
                    time = (int)(time * 1.0 / ans + 0.5);
                printf("%d %d\n", ans, time);
                goto a;
            } else {
                if (vis == 'S') {
                    //					if (m[ID].flag == 0)
                    //					{
                    m[ID].time = h * 60 + mins;
                    m[ID].flag = 1;
                    //		 			}
                } else if (vis == 'E') {
                    if (m[ID].flag == 1) {
                        ans++;
                        time += (h * 60 + mins) - m[ID].time;
                        m.erase(ID);
                    }
                }
            }
        }
    }
}

Last update: May 4, 2022
Back to top