L1-039 古风排版
Statement
Metadata
- 作者: 陈越
- 单位: 浙江大学
- 代码长度限制: 16 KB
- 时间限制: 400 ms
- 内存限制: 64 MB
中国的古人写文字,是从右向左竖向排版的。本题就请你编写程序,把一段文字按古风排版。
输入格式
输入在第一行给出一个正整数
输出格式
按古风格式排版给定的字符串,每列
输入样例
输出样例
Solution
#include <ctype.h>
#include <algorithm>
#include <climits>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <ctime>
#include <deque>
#include <iomanip>
#include <iostream>
#include <limits>
#include <map>
#include <numeric>
#include <queue>
#include <set>
#include <sstream>
#include <stack>
#include <string>
#include <vector>
using namespace std;
typedef long long ll;
typedef long double ld;
typedef unsigned long long ull;
typedef pair<int, int> pii;
typedef pair<ll, ll> pll;
const double PI = 3.14159265358979323846264338327;
const double E = exp(1);
const double eps = 1e-6;
const int INF = 0x3f3f3f3f;
const int maxn = 1e3 + 5;
const int MOD = 1e9 + 7;
string ans[maxn];
int main() {
int n;
scanf("%d", &n);
getchar();
string s;
getline(cin, s);
int len = s.size();
if (len <= n) {
int i;
for (i = 0; i < len; i++) cout << s[i] << endl;
for (; i < n; i++) printf(" \n");
} else {
int cur = len / n;
if (len % n)
cur++;
int count = 0;
string temp;
for (int i = 0; i < n; i++) {
temp.clear();
temp += s[count];
ans[i].insert(0, temp);
count++;
}
for (int j = 1; j < cur - 1; j++) {
for (int i = 0; i < n; i++) {
string temp = "";
temp += s[count++];
ans[i].insert(0, temp);
}
}
for (int i = 0; i < n; i++) {
if (count < s.size()) {
temp.clear();
temp += s[count];
ans[i].insert(0, temp);
count++;
} else
ans[i].insert(0, " ");
}
for (int i = 0; i < n; i++) {
cout << ans[i] << endl;
}
}
}
Last update: May 4, 2022