L1-031 到底是不是太胖了
Statement
Metadata
- 作者: 陈越
- 单位: 浙江大学
- 代码长度限制: 16 KB
- 时间限制: 400 ms
- 内存限制: 64 MB
据说一个人的标准体重应该是其身高(单位:厘米)减去100、再乘以0.9所得到的公斤数。真实体重与标准体重误差在10%以内都是完美身材(即 | 真实体重
输入格式
输入第一行给出一个正整数N
(N
行,每行给出两个整数,分别是一个人的身高H
(120 H
W
(50 W
输出格式
为每个人输出一行结论:如果是完美身材,输出You are wan mei!
;如果太胖了,输出You are tai pang le!
;否则输出You are tai shou le!
。
输入样例
输出样例
Solution
#include <ctype.h>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <deque>
#include <iostream>
#include <map>
#include <numeric>
#include <queue>
#include <set>
#include <sstream>
#include <stack>
#include <string>
#include <vector>
using namespace std;
typedef long long LL;
const double PI = 3.14159265358979323846264338327;
const double E = 2.718281828459;
const double eps = 1e-6;
const int MAXN = 0x3f3f3f3f;
const int MINN = 0xc0c0c0c0;
const int maxn = 1e5 + 5;
const int MOD = 1e9 + 7;
int main() {
int n;
cin >> n;
while (n--) {
double a, b;
cin >> a >> b;
double temp;
temp = (a - 100) * 0.9 * 2;
if (fabs(b - temp) < temp * 0.1)
printf("You are wan mei!\n");
else if (b < temp)
printf("You are tai shou le!\n");
else
printf("You are tai pang le!\n");
}
}
Last update: May 4, 2022