L1-010 比较大小
Statement
Metadata
- 作者: 杨起帆
- 单位: 浙大城市学院
- 代码长度限制: 16 KB
- 时间限制: 400 ms
- 内存限制: 64 MB
本题要求将输入的任意3个整数从小到大输出。
输入格式
输入在一行中给出3个整数,其间以空格分隔。
输出格式
在一行中将3个整数从小到大输出,其间以“->”相连。
输入样例
输出样例
Solution
#include <ctype.h>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <deque>
#include <iostream>
#include <map>
#include <numeric>
#include <queue>
#include <set>
#include <sstream>
#include <stack>
#include <string>
#include <vector>
using namespace std;
typedef long long LL;
const double PI = 3.14159265358979323846264338327;
const double E = 2.718281828459;
const double eps = 1e-6;
const int MAXN = 0x3f3f3f3f;
const int MINN = 0xc0c0c0c0;
const int maxn = 1e5 + 5;
const int MOD = 1e9 + 7;
int main() {
int a[3];
for (int i = 0; i < 3; i++) scanf("%d", &a[i]);
sort(a, a + 3);
for (int i = 0; i < 3; i++) {
if (i)
printf("->");
printf("%d", a[i]);
}
cout << endl;
}
Last update: May 4, 2022