L1-005 考试座位号
Statement
Metadata
- 作者: 陈越
- 单位: 浙江大学
- 代码长度限制: 16 KB
- 时间限制: 200 ms
- 内存限制: 64 MB
每个 PAT 考生在参加考试时都会被分配两个座位号,一个是试机座位,一个是考试座位。正常情况下,考生在入场时先得到试机座位号码,入座进入试机状态后,系统会显示该考生的考试座位号码,考试时考生需要换到考试座位就座。但有些考生迟到了,试机已经结束,他们只能拿着领到的试机座位号码求助于你,从后台查出他们的考试座位号码。
输入格式
输入第一行给出一个正整数 准考证号 试机座位号 考试座位号
。其中准考证号
由 16 位数字组成,座位从 1 到
考生信息之后,给出一个正整数
输出格式
对应每个需要查询的试机座位号码,在一行中输出对应考生的准考证号和考试座位号码,中间用 1 个空格分隔。
输入样例
输出样例
Solution
#include <ctype.h>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <deque>
#include <iostream>
#include <map>
#include <numeric>
#include <queue>
#include <set>
#include <sstream>
#include <stack>
#include <string>
#include <vector>
using namespace std;
typedef long long LL;
const double PI = 3.14159265358979323846264338327;
const double E = 2.718281828459;
const double eps = 1e-6;
const int MAXN = 0x3f3f3f3f;
const int MINN = 0xc0c0c0c0;
const int maxn = 1e5 + 5;
const int MOD = 1e9 + 7;
struct node {
int num;
string ID;
} temp;
int main() {
int n;
int i;
int vis;
map<int, node> m;
m.clear();
cin >> n;
for (i = 0; i < n; i++) {
cin >> temp.ID;
scanf("%d%d", &vis, &temp.num);
m[vis] = temp;
}
cin >> n;
for (i = 0; i < n; i++) {
scanf("%d", &vis);
cout << m[vis].ID << " " << m[vis].num << endl;
}
}
Last update: May 4, 2022