Skip to content

L1-004 计算摄氏温度

Statement

Metadata

  • 作者: 陈建海
  • 单位: 浙江大学
  • 代码长度限制: 16 KB
  • 时间限制: 400 ms
  • 内存限制: 64 MB

给定一个华氏温度F,本题要求编写程序,计算对应的摄氏温度C。计算公式:C = 5\times (F-32)/9。题目保证输入与输出均在整型范围内。

输入格式

输入在一行中给出一个华氏温度。

输出格式

在一行中按照格式“Celsius = C”输出对应的摄氏温度C的整数值。

输入样例

150

输出样例

Celsius = 65

Solution

#include <ctype.h>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <deque>
#include <iostream>
#include <map>
#include <numeric>
#include <queue>
#include <set>
#include <sstream>
#include <stack>
#include <string>
#include <vector>
using namespace std;

typedef long long LL;
const double PI = 3.14159265358979323846264338327;
const double E = 2.718281828459;
const double eps = 1e-6;
const int MAXN = 0x3f3f3f3f;
const int MINN = 0xc0c0c0c0;
const int maxn = 1e5 + 5;
const int MOD = 1e9 + 7;

int main() {
    int n;
    cin >> n;
    printf("Celsius = %d\n", (int)(5.0 * (n - 32) / 9));
}

Last update: May 4, 2022
Back to top