Skip to content

L1-003 个位数统计

Statement

Metadata

  • 作者: 陈越
  • 单位: 浙江大学
  • 代码长度限制: 16 KB
  • 时间限制: 400 ms
  • 内存限制: 64 MB

给定一个 k 位整数 N = d_{k-1}10^{k-1} + \cdots + d_1 10^1 + d_0 (0\le d_i \le 9, i=0,\cdots ,k-1, d_{k-1}>0),请编写程序统计每种不同的个位数字出现的次数。例如:给定 N = 100311,则有 2 个 0,3 个 1,和 1 个 3。

输入格式

每个输入包含 1 个测试用例,即一个不超过 1000 位的正整数 N

输出格式

N 中每一种不同的个位数字,以 D:M 的格式在一行中输出该位数字 D 及其在 N 中出现的次数 M。要求按 D 的升序输出。

输入样例

100311

输出样例

0:2
1:3
3:1

Solution

#include <ctype.h>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <deque>
#include <iostream>
#include <map>
#include <numeric>
#include <queue>
#include <set>
#include <sstream>
#include <stack>
#include <string>
#include <vector>
using namespace std;

typedef long long LL;
const double PI = 3.14159265358979323846264338327;
const double E = 2.718281828459;
const double eps = 1e-6;
const int MAXN = 0x3f3f3f3f;
const int MINN = 0xc0c0c0c0;
const int maxn = 1e5 + 5;
const int MOD = 1e9 + 7;

int main() {
    string s;
    cin >> s;
    int len = s.size();
    map<char, int> m;
    m.clear();
    for (int i = 0; i < len; i++) {
        m[s[i]]++;
    }
    map<char, int>::iterator it;
    for (it = m.begin(); it != m.end(); it++) cout << it->first << ":" << it->second << endl;
}

Last update: May 4, 2022
Back to top